Start a new topic

firmware upgrade

Hi 

Just received my openevse 5.5 board

However, upon checking some of the options it seems some are missing

My version is 7.1.3, but the latest is 8.2.0.

I bit dissapointed that I did not received a module with the last release

Looking at the upgrade instructions, and they don't seem to have been updated

https://openevse.dozuki.com/Guide/How+to+Load+OpenEVSE+Firmware+(WinAVR)/7

On one of the last steps, it mention yo need  3 files; flash.bat, open_evse.hex and eeprom_24.bin

However, on the repository for the last release ( 8.2.0)  there are a couple of hex files ( I assume I should use openevse.hex), there is no  bin o flash.bat files

What am I missing?

should just run the command to flash the hex file as per the Readme file:

`$ avrdude -p atmega328p -B6 -c usbasp -P usb -e -U flash:w:firmware.hex`


Any help appreciated


Hi Javier


Thank you for the advice regarding the Wroom 32 board.

I have just bought a Nodemcu-32S and trying to set up the platformio to compile the code but struggling with an <Arduino.h> not found error. It's just driving me crazy. Do you have any idea where shall I dig into?


Many thanks,

George

txt
(5.66 KB)

Hi Javier,

I was able to compile the code at the end so I have the latest firmware and it works with my Nodemcu-32S board.

Now I'm hunting components to build the hardware. Most of components I have already, but the current transformers (CR8420-1000-G and CR8450-1000) I'm not able to find anywhere.

Thank you for your help!

glad you managed to program the board

can't you buy the current transformers from USA?

I know is not ideal, but at least you know they work!


Javier

What version of the wifi are you trying to use?

As far as I know you can only use the Node MCU board with version 2.x

In which  case is better you use a precompiled file

If you want to use version 4.x upwards you will need to use the new boards

I found the procedure to program the modemcu on this youtube video:

https://www.youtube.com/watch?v=p6vUb3gqjHM&t=1165s

It also contains the location and instructions on how to program it ( its in spanish, but is very easy to follow

Good luck!

Hi,

There is support for Nodemcu-32S in platformia.ini file. The problem is not the Nodemcu-32S itself, I cannot compile the code even with default configuration for the standard openevse_wifi_v1.

There is no precompiled binary for Nodemcu-32S, are you able to make one?

I will take a look on the video, thank you for that.

That video was for the older nodemcu, so I doubt it will help you. I will try this afternoon when I have a minute. What specific board do you have?

The exact board is NodeMCU-32S ESP32 Development Board. You can find it in platformio.ini as the first env registry:

[env:openevse_nodemcu-32s]


Thank you for your help!

image

image


I have managed to compile the code

All I did was (on platformio): Import Arduino Project - Select Board ( NodeMCU-32S), then the location where I saved the (unzipped) files, then click Import at the bottom

Afterwards I click on the "Build" tickbox at the bottom

I'm not sure if this is the right way of doing it- normally I create a new project then I add all the bits, but this time I did it this way

Here are the compiled files( not sure which one you need, though:

https://www.mediafire.com/folder/mxuon5qisbfx3/nodemcu-32+code

Let me know if this helped

Javier,

Thank you! I will give it a try. Also I will try to compile the way you did.
Will let you know.

 

Hi Javier,

I have successfully flashed the firmware. The guide says that it should broadcast a WiFi access point (AP) OpenEVSE_XXXX at first boot but it does not. I tried to load the openevse_wifi_v1.bin and the openevse_huzzah32.bin, same result. When loading the WiFiAccessPoint example skatch from Arduino IDE the new WiFi network is created. Should the WiFi module be connected to the EVSE board to be able to broadcast the SSID?

I've opened the serial console and found the following coming continuously:


10:42:47.081
10:42:47.081 rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
10:42:47.125 invalid header: 0xffffffff
10:42:47.168 invalid header: 0xffffffff
10:42:47.214 invalid header: 0xffffffff
10:42:47.258 invalid header: 0xffffffff
10:42:47.302 invalid header: 0xffffffff
10:42:47.347 invalid header: 0xffffffff
10:42:47.394 invalid header: 0xffffffff
10:42:47.435 invalid header: 0xffffffff
10:42:47.478 ets Jul 29 2019 12:21:46
10:42:47.478
10:42:47.478 rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
10:42:47.523 invalid header: 0xffffffff
10:42:47.568 invalid header: 0xffffffff
10:42:47.612 invalid header: 0xffffffff
10:42:47.664 invalid header: 0xffffffff
10:42:47.701 invalid header: 0xffffffff
10:42:47.745 invalid header: 0xffffffff
10:42:47.789 invalid header: 0xffffffff
10:42:47.834 invalid header: 0xffffffff
10:42:47.878 ets Jul 29 2019 12:21:46


It looks like the board is not able to boot.

The WiFi board works on its own, it does not need the main board I think you may have flashed the board, but is not the right code. I did that once and the board was completely unresponsive Where do you live? I have a spare wroom32 board I can flash and send it to you.i paid very little on aliexpress

I have a few Wroom32 boards but I was curious about what I'm doing wrong.


So, at the end I've got it flashed, the correct procedure came from this topic:

https://community.openenergymonitor.org/t/esp32-firmware-problems/15685


The bootloader.bin and partitions.bin files needs to be flashed to.They can be downloaded here:

https://github.com/OpenEVSE/ESP32_WiFi_V4.x/releases


You can find the files under release V4.1.1 in Assets

After that, using the esptool.py the command will be (change the port number to one you have):


python -m esptool --chip esp32 --port com2 --baud 460800 --before default_reset --after hard_reset write_flash -z --flash_mode dio --flash_freq 40m --flash_size detect 0x1000 bootloader.bin 0x8000 partitions.bin 0x10000 firmware.bin


Thank you Javierfor your king help!




As they say: well is when it ends well Ienjoy!

Hi Javie,


Which environment do you use for compiling? I use VS Code with Platformio addon on Windows 10.

After importing the arduino project as you did I still have the same "missing Arduino.h" compile error.

Also I need to comment out the line

platform = espressif32@1.11.1


because it is not able to find it and uncomment the line:
#platform = https://github.com/platformio/platform-espressif32.git


After that, building the project it downloads the platform-espressif32and fails with "Arduino.h not found" error.

So I think there is something missing in my dev environment.

Login or Signup to post a comment