Start a new topic

Is RAPI enabled by default?


I'm trying to hook up my OpenEVSE to a Raspberry Pi using this manual. I've bought both a FTDI USB cable and a PL2303HX cable. When I connect the pins as described the EVSE boots and display starts. However, no matter how I try to connect the cables, I do not get any communication going between the raspberry and the EVSE. 

When trying to connect using:

screen /dev/ttyUSB0 115200

I get a blank screen, entering $ does not do anything.


- Do I need to enable the RAPI somehow? Or is it enabled by default (FW 3.10.3)?

- Does anybody have experience using PL2303HX or FT232RL?

Thanks for your help!

RAPI is enabled by default. You may want to try swapping RX and TX lines.

1 person likes this

That was the trick indeed!

So for PL2303HX USB cables, the order is:

1. Black

2. Empty

3. Red

4. Green (Txd according to spec)

5. White (Rxd according to spec)

6. Empty


Login or Signup to post a comment