Start a new topic

firmware upgrade


Just received my openevse 5.5 board

However, upon checking some of the options it seems some are missing

My version is 7.1.3, but the latest is 8.2.0.

I bit dissapointed that I did not received a module with the last release

Looking at the upgrade instructions, and they don't seem to have been updated

On one of the last steps, it mention yo need  3 files; flash.bat, open_evse.hex and eeprom_24.bin

However, on the repository for the last release ( 8.2.0)  there are a couple of hex files ( I assume I should use openevse.hex), there is no  bin o flash.bat files

What am I missing?

should just run the command to flash the hex file as per the Readme file:

`$ avrdude -p atmega328p -B6 -c usbasp -P usb -e -U flash:w:firmware.hex`

Any help appreciated

That video was for the older nodemcu, so I doubt it will help you. I will try this afternoon when I have a minute. What specific board do you have?

The exact board is NodeMCU-32S ESP32 Development Board. You can find it in platformio.ini as the first env registry:


Thank you for your help!



I have managed to compile the code

All I did was (on platformio): Import Arduino Project - Select Board ( NodeMCU-32S), then the location where I saved the (unzipped) files, then click Import at the bottom

Afterwards I click on the "Build" tickbox at the bottom

I'm not sure if this is the right way of doing it- normally I create a new project then I add all the bits, but this time I did it this way

Here are the compiled files( not sure which one you need, though:

Let me know if this helped


Thank you! I will give it a try. Also I will try to compile the way you did.
Will let you know.


Hi Javier,

I have successfully flashed the firmware. The guide says that it should broadcast a WiFi access point (AP) OpenEVSE_XXXX at first boot but it does not. I tried to load the openevse_wifi_v1.bin and the openevse_huzzah32.bin, same result. When loading the WiFiAccessPoint example skatch from Arduino IDE the new WiFi network is created. Should the WiFi module be connected to the EVSE board to be able to broadcast the SSID?

I've opened the serial console and found the following coming continuously:

10:42:47.081 rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
10:42:47.125 invalid header: 0xffffffff
10:42:47.168 invalid header: 0xffffffff
10:42:47.214 invalid header: 0xffffffff
10:42:47.258 invalid header: 0xffffffff
10:42:47.302 invalid header: 0xffffffff
10:42:47.347 invalid header: 0xffffffff
10:42:47.394 invalid header: 0xffffffff
10:42:47.435 invalid header: 0xffffffff
10:42:47.478 ets Jul 29 2019 12:21:46
10:42:47.478 rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
10:42:47.523 invalid header: 0xffffffff
10:42:47.568 invalid header: 0xffffffff
10:42:47.612 invalid header: 0xffffffff
10:42:47.664 invalid header: 0xffffffff
10:42:47.701 invalid header: 0xffffffff
10:42:47.745 invalid header: 0xffffffff
10:42:47.789 invalid header: 0xffffffff
10:42:47.834 invalid header: 0xffffffff
10:42:47.878 ets Jul 29 2019 12:21:46

It looks like the board is not able to boot.

The WiFi board works on its own, it does not need the main board I think you may have flashed the board, but is not the right code. I did that once and the board was completely unresponsive Where do you live? I have a spare wroom32 board I can flash and send it to you.i paid very little on aliexpress

I have a few Wroom32 boards but I was curious about what I'm doing wrong.

So, at the end I've got it flashed, the correct procedure came from this topic:

The bootloader.bin and partitions.bin files needs to be flashed to.They can be downloaded here:

You can find the files under release V4.1.1 in Assets

After that, using the the command will be (change the port number to one you have):

python -m esptool --chip esp32 --port com2 --baud 460800 --before default_reset --after hard_reset write_flash -z --flash_mode dio --flash_freq 40m --flash_size detect 0x1000 bootloader.bin 0x8000 partitions.bin 0x10000 firmware.bin

Thank you Javierfor your king help!

Hi Javie,

Which environment do you use for compiling? I use VS Code with Platformio addon on Windows 10.

After importing the arduino project as you did I still have the same "missing Arduino.h" compile error.

Also I need to comment out the line

platform = espressif32@1.11.1

because it is not able to find it and uncomment the line:
#platform =

After that, building the project it downloads the platform-espressif32and fails with "Arduino.h not found" error.

So I think there is something missing in my dev environment.

As they say: well is when it ends well Ienjoy!

I'm running windows 10 with visual studio code + platformio

However, I had already installed Arduino IDE, so I don't know if reusing some of the libraries

Just now I have recompiled the code on platformio, in this case what I did was to decompress the github 4.1.2 zip file to a location on my drive, then on Platformio click on Open Project and point the project to that location. I did recompile and flashed and worked first time!

However, I do not know how to change the board, so it used the wroom32 board

Even if I knew how to change the board , I don't have an MCU32 board to test

ok, I have recompiled the code using "import Arduino Project", selected the (first) Node MCU 32S (not sure why there more than 2 instances).,I did NOT select "Use libraries installed by Arduino IDE"

Then I pointed to the location of the decomppressed zip folder. Afterwards I compiled and after some warnings it finished compiling with the resulting firmware files

As I said if I had a board I would flash to test, but I don't have one

I'm an idiot!

Just found that I was compiling with the "default_envs = openevse_wifi_v1" instead of "default_envs = openevse_nodemcu-32s"

on the platformio.ini file

This explains why the code would not work for you!


 I tried to compile and the first time I got an error:

FileNotFoundError: [Errno 2] No such file or directory: 'D:\\Downloads\\ESP32_WiFi_V4.x-4.1.2\\.pio\\build\\openevse_wifi_v1\\.sconsign39.tmp'

After that I tried again and now compiled succesfully

I have uploaded the files to the same location:

I will now try compile fronm scratch

I will let you know how it goes


NOW I have compiled from scratch:

From platformio Open Project , select location of unzipped folder

Then modify platformio.ini file, so it says: "default_envs = openevse_nodemcu-32s"

Compile and flash

I have copied the last version of the files same place:

Hope this works for you



The latest binary you compiled works just fine, thank you.
Which version of the "espressif32" are you using in your environment?
Login or Signup to post a comment