Start a new topic

Limit max current values to 40A or less?

Quick question: I just built the 40A advanced kit, which is working great. I'm interested in disallowing the "max current" setting from ever being set above 40A. Is it possible to change the allowed values? 

I've integrated OpenEVSE with my Homeassistant server, and it's nice to be able to see parameters and change the "max current" right from my home server interface. But I'm a little worried about fat-fingering the max current value. The integration pulls the possible values from OpenEVSE, and just like the OpenEVSE interface it has a drop-down with values ranging from 6A to 80A. I'd like to change this to be 6A to 40A. Any ideas? Thanks!

I think I found the solution after looking through some github discussions. Posting here in case it helps someone in the future. The following RAPI command (added in 2020 I believe) seems to set the max hardware charging capacity to 40A:

$SC 40 M

After a restart, the "Level 2 Maximum" is now 40A, and the "Max Current" values only go to 40A, and likewise the Homeassistant integration is also capped at 40A. I can sleep a bit more comfortably now. Thanks!

There is a one-time setting to set the station hardware max.

Log into the OpenEVSE WiFi Portal - Enable developer mode - In the RAPI tab enter the command $SC 40 M

This will set the station to 40A Maximum. 

Thanks. I actually discovered this (looking through github comments and changes) and tried to post it as a reply to my own post, but as a new user I think it was flagged for moderation. Anyway, that command works beautifully! Thanks!

Login or Signup to post a comment