Start a new topic

Open EVSE won't charge

Advanced kit diy assembly. After assembly, tried charging. EVSE boots fine goes into ready, 12A. Tried changing to 15A, only changes on a restart Before plugging in, EVSE said ready. When plugged into car, contactor " clunk" is not heard , EVSE says connected but charging did not start. Have double, triple checked wiring, pilot definitely connected to correct terminal, coils definitely connected correctly, have had sparkie friend who has a assembled a few of these check my work. We connected 12v to the contactor coil and it activated , so contractor works. Have checked all continuity, earth is connected via the backplane , all wires are correct. Have tried on two cars, same issue. Could this be a dud controller? Do I have to order another one to check?

The resistor in the handle is for the max capacity of the cable. Pilot is the max capacity of the station.


It is as simple as adding the correct resistor. Here is a guide that may help.

https://openevse.dozuki.com/Guide/How+to+build+an+IEC+-+Type+2+Mennekes+Cable/35?lang=en



Thanks for your assistance, will try this soon and report back. Hope you get on top of your backlog soon.

Have checked and I don't see the retaining ring but there is nothing to interfere with the contactor.
Photos of the inside here:
https://photos.app.goo.gl/fUMkKqTRDzqH5BDg8
I will try moving the black wire as you suggested - when I find out how - but in the meantime I might attach some wires to that terminal so see if 12V appears when the car is connected.


Link to photos of inside of OpenEVSE

I have tried to take as many photos as possible.
As you can see no mechanical obstruction of the Struthers Dunnn. I am not sure where the retaining ring is but I don't see anything that would prevent the relay from working. Also, we put 12V onto the coil wires and it did KLAK.
I will try moving the black wire from the board to the open position - need to find out how first. But also will operate the OpenEVSE open (safely) and attach a wire to measure if 12V is being provided on the connector.


@Anthony the command for relay delay and power is $Z0


Here is a picture of the retaining ring. It should be easy to tell if the relay moves freely by pressing the contacts down by hand (with the power off).


I wrote the command here from memory, when I sent it I was consulting your previous comments. So sent the correct one. The relay feels like it moves freely when pushing the arms down. One other thing I didn't mention is that when setting the current from the app, it doesn't "take". The openEVSE has to be restarted for the new setting to take effect. In other openEVSE I have used it's immediate. I think we have eliminated all possible known causes, what more do I have to do? I think I more need to try another board. Please send another one and I will return the current one. I really need to get this working and we've tried everything.

@Antony -The odds that both relay outputs on your controller are bad are essentially zero. We have never seen this.  We can exchange controllers if you wish however we do not think it will resolve your issue.


Older WiFi firmware does not update the current value immediately, even though the current was written to the controller. You can verify this using the RAPI commands. 


Send a set current (this example sets 24A)

$SC 24


The controller should respond $OK


Then send the get current command

$GC


It should respond with an Ok and 24


The latest WiFi firmware is here:

https://github.com/OpenEVSE/ESP32_WiFi_V4.x/releases

I will update the WiFi firmware. However I'm still stuck, having tried absolutely everything. If you don't think it's the controller then what else could it be , given the now multiple remedies that we have tried and failed to fix the issue?

We are making progress, your issue with the handle seems to be resolved now. 


We clearly understand the "No Ground" the issue.  Assuming your earth ground is good. The false positive can only be two things, electrical or mechanical.


Electrical -  "OpenEVSE now goes ready -  plug car in - connected - KLAK" proves the output on the controller is working. I am not very familiar with the "EU firmware" you have loaded it likely does not have Adjustable relay power enabled however if it does, adjustable power was disabled in software with $Z0 command.


Mechanical - The pictures show no wires are providing a physical blockage. If the retaining clip is Okay and the relay is smooth easy to close by hand then the only other mechanical issue we have seen is the relay contact gap is too large. The Gap should be about 2mm. The gap can be adjusted by squeezing the top contact plate and the stop on the side. 





I measured the contact gap - I had a strip of aluminium 1mm thick, doubled it and that fitted - so gap ( on L and R gaps ) is almost exactly 2mm.





What more could I possibly do apart from replacing the controller now?

Which version of the firmware should I load ( I don't have a firmware programmer so need to go to a friend who has one and is running 8.2.0 eu  successfully

When I send $SC 10 Then $GC Returns >$OK 6 16 10 10^11
By the way, I certainly can't lift the arms of the Struthers dunn as high you do in that picture.. and I've yet to find the "retaining pin" you refer to.
I mean retaining ring
Got a 6 pin programmer, flashed to 7.1.3. works... So the upshot of this is, firstly no resistor in the handle PP to PE. As a result of that I had a go at upgrading firmware, which compounded the error.. All's well that ends well. Thanks for your help. One small thing, it seems the current can't be changed (without a restart) unless the car is connected.
Login or Signup to post a comment