Start a new topic

Wifi Firmware not compatible with EVSE Firmware?

I got Glyn's email earlier today that the WiFi firmware version 2.9.1 was released.  I thought "what the heck, why not?" and so logged into the OpenEVSE Wifi page, and uploaded the bin file.  I did not note the previous firmware version, but I do recall upgrading it once or twice before since the purchase in 3/2017.  It has been at least a year, I believe, since I did so.


After the upload finished, the webpage did not come back, but  I did find the OpenEVSE_XXXXXX SSID.  I hit that, and put it back on the home SSID, and it grabbed its reserved IP without issue.


Webpage now says only "Loading, please wait... (/)".  Restarts and power cycles do not change this.


My EVSE Hardware from my order confirmation in 3/2017 is "OpenEVSE Kit - Level1 & Level2 50A Deluxe", and the EVSE firmware level (From the restart menu) is 3.11.3.


I found an earlier post here that mentioned that the minimum firmware level for WiFi is 4.8.0, but mine was working fine prior to this upgrade.


Do I need to 

  1. upgrade the EVSE firmware or
  2. downgrade the Wifi firmware?

If so, is there a way to do this without the cables?  I do not have any of the USB/Serial interface cables, but that should not be an issue to acquire.  I thought perhaps telnet, but I scanned the IP for commonly used ports, and did not notice any open ports besides 80.

Pictures are available if they'll help.

Thanks in advance for any ideas, assistance, and/or solutions.

Timothy


dinking around,  I have found the /update and /rapi sub-pages, so I can certainly easily try to downgrade the WiFi firmware if that is required, although I'd prefer to stay on the latest if possible.


The #system and #services URLs are not available, however, and still show only the "Loading, please wait... (/)".

The RAPI Get-Version shows a tad more info than the 3.11.3


 

$GV
>$OK 3.11.3 1.0.3

 

Reloaded the firmware, and it works fine now 

I had a similar experience last year when attempting to update the ESP8266 WiFi firmware from 2.8.2 to (some version <2.9.0).  My solution involved flashing the Atmel's firmware from 3.11 to 5.01 at the same time.  Because I don't work with this kind of hardware regularly, I need to keep notes for reference, and I documented my journey here:


http://nissandiesel.dyndns.org/viewtopic.php?f=12&t=3857 


The 2015-era "updating firmware" guide at https://openevse.dozuki.com/Guide/How+to+Load+OpenEVSE+Firmware+(WinAVR)/7 is Windows-centric, so my notes above translate to a (Ubuntu) Linux recipe that led to success here.


Within the last two weeks, I have subsequently used the webUI to update the ESP8266's firmware to 2.9.0, then 2.9.1, without further incident.

Thanks, Al;


I'm gonna spring for the OpenEVSE Programmer, and try to update my firmware (Windows 10, BTW).

Login or Signup to post a comment