Start a new topic


Good afternoon . For a long time, charging based on the OPENEVSE 4 (4.8) controller worked perfectly. And now here is a message: 


I tried to set the charging current 6 - 10 - 12 - 16 - 20 Amperes.
The device turns on the contactor - and turns off after 3-5 seconds.
BMW  i3. What could be the problem ??
Save, disappear!

See the photo 

Overcurrent is an extra safety feature not required by any standards. It uses the current measurement coil, if the reading from the coil is higher than the set pilot value for a length of time the feature will activate.

There are settings in the source code to enable/disable and set the trip level and time.

When watching your LCD does the current reading exceed the pilot you have set? 

Good afternoon . Unfortunately, I can’t say exact data on the issue of readings from the coil in comparison with the set values. The device is in another city and I have not received it yet to check it. Is there any software that does not have this check? Because the source code compiles with an error and I have not been able to make the final firmware file for a long time.

The latest verified release 5.0.1 compiles fine.

Here are the parameters from openevse.h. Default is 5A over pilot for 5 seconds will trip. Commenting out both will disable the feature.

#ifdef AMMETER

// if OVERCURRENT_THRESHOLD is defined, then EVSE will hard fault in

// the event that the EV is pulling more current than it's allowed to

// declare overcurrent when charging amps > pilot amps + OVERCURRENT_THRESHOLD


// go to error state overcurrent by OVERCURRENT_THRESHOLD amps


#define OVERCURRENT_TIMEOUT 5000UL // ms

Login or Signup to post a comment