Start a new topic

Older EVSE was working great, but got wet

I don't have a display to see any errors... but, now it boots and goes "click". All good, totally normal.  Then when I plug the J1772 into the vehicle, it goes click click click click... engaging and disengaging the relay about once a second.  I checked the test lines and the relay is getting power to them.  I visually inspected the board, it looks fine, I don't see any blown components or fuses.  It did get wet... so who knows, but if anyone else has seen this and knows the fixes, let me know.  What else can I do to diagnose the issue?



This is an OpenEVSE v4


I pulled the Pilot DCDC, and dropped in a spare from an older project.  That fixed it.  I haven't tried to diagnose exactly how it's unhappy, but I bet it isn't generating a consistent voltage.


This is the part that I replaced.

I think I have this knock-off in it now, but the faulty one in the circuit was the original.  It obviously got wet and shorted internally.

Login or Signup to post a comment