Start a new topic

GoPlug (relabeled Openevse Advanced) upgrade failed

I had the EVSE connected to my wifi; all was normal.  The GoPlug EVSE came with Wifi 2.7.5.  At the wifi firmware update, I downloaded and selected the file 2.7.6 and updated.

The EVSE now does not connect to wifi (goplug or openevse), it does boot up from a power up, but menus are extremely limited (to Max Current setting only).  It appears the update failed.  I'd appreciate some help.


The display menus are driven by the controller firmware, updating WiFi does not affect the menu options. GoPlug default firmware is limited.

Is your station connecting to your home network? If so it will not broadcast its own network. If you power cycle you should see the network info and the IP address.

I’m having the exact same problem. Tried updating via the web interface from 2.7.5 (what it came with) to 2.7.8 (latest from here and now it disappeared from my network and it is also not broadcasting any SSID. Opened it up and there’s a red light. Tried holding down the buttons and nothing changed. Were you able to fix the problem?

I was able to fix the issue I posted by flashing the OpenEVSE version of the code using the programmer cable and following the instruction on the OpenEVSE site.  Since the GoPlug unit is sold as a finished product (not a kit of parts), I would think you could get customer support to help you out if you could find it.

Yep, customer support is already on it. We are communicating with the customer via a Open Support ticket.


Thanks Nick, They suggested using the USB Serial Programmer ( and esptool, python and pyserial to recover it or the option to send it in for them to fix. I think I’ll try loading the firmware again myself through the programmer first as you suggest and see if that fixes the problem.

Since someone else is bound to run into this too - What I ended up doing was reflashing the wifi board.

Disconnect power on the EVSE and open it up.  Disconnect the ribbon cable on the wifi "huzzah" board.  I used a USB to TTL Adapter / USB to Serial (FTDI) Converter Programmer and connected VCC on the programmer to V+ on the ESP8266 wifi module, GND to GND, TXD to RX, and RXD to TX.  Then used the following commands on linux:

# Download the firmware.bin file from the latest release on

# hold GPIO0 button then reset button on the wifi board, this puts it into programming mode --port /dev/ttyUSB0 erase_flash

# hold GPIO0 button then reset button on the wifi board, this puts it into programming mode again --port /dev/ttyUSB0 --baud 460800 write_flash --flash_size=detect 0 firmware.bin

Pull the cables and reinstall the original cables and close up the unit and restore power.  It should boot up and say the version of the wifi module and the SSID after the normal openevse info on the LCD.

Thanks for posting your findings.  I did flash both the power controller and the wifi module before powering up the unit and confirming it was back to life.  I wasn't sure which one or if both steps were required to fix it; now we know.

Login or Signup to post a comment