Start a new topic

OpenEVSE v5.5 board not holding relay closed

Hi, I have a brand new, less than 48 hours old v5.5 board which worked for a few good charges, but now won't hold the relay closed for more than about 30 seconds.  It starts humming, then releases and gives a grounding error.  The ground error makes since, as the test is expecting a closed relay.  Disconnected, the relay draws 158mA, which seems to be in spec.  I suspect this is an issue with the Q2 transistor not sinking enough current, and the coil voltage falls off.  Any thoughts?



1 person likes this idea

Problem solved.  There is PWM output on the relay module.  Humming and disconnect means it is set too low.  

Advice from Open EVSE:

OpenEVSE hardware version 5.5 and above supports variable relay power. The relay is closed at full power then after a set time the power is decreases. Differences in hardware and temperature can require slightly more hold power.

To alter the settings login to OpenEVSE WiFi

Click the System tab

Enable Developer Mode


Click the RAPI tab

Enter the command $Z0 xxx yyy

xxx = the number of ms to run 100% power

yyy = the power out of 255 (example 90/255 = 0.35 or 35% power)

Recommended setting is $Z0 100 105


I've got the exact same problem.  I received my unit a few days ago and just got it built and tried today.  I have a older unit (2 yrs old) and it's working like a champ.  With this one, under low amps it works fine (<10A).  Greater than 11A you can start hearing it hum.  If I disable the Ground Monitoring it will go up to ~21A before it'll reset.  


I found the solution, but the forum is not showing my post until it is "approved."  

Bottom line, go to dev mode, RAPI, and type the following:

$Z0 100 105

The relay pin is using PWM after it closes the relay to reduce the hold voltage.  This is causing the humming, and eventually it lets go.  This command fixed mine in one shot.  

Here's how it works:

Enter the command $Z0 xxx yyy

xxx = the number of ms to run 100% power

yyy = the power out of 255 (example 90/255 = 0.35 or 35% power)

Hope this helps,


That worked but I'd be interesting to know what the defaults are and why I had to change it???

Okay I see the defaults in the source 25 75. The $Z0 RAPI command saves it to eeprom so at least it’ll stay after reboots. Still wondering why I had to change it.
I'm not sure either. Maybe different relays used in development. A feedback loop that increases holding power after a couple of disconnects during charging would be a way to fix this.

Variations are caused by the temperature, relay gap and spring tension.  The feature was introduced in the winter and worked great, summer brought higher temperatures and some relays do not hold with the defaults.

This was a very irritating problem for me as well.  I had two of the units not working correctly.  The problem I had was using the command $Z0 RAPI to make the changes stick.  So thank you for mentioning this.

I feel like this thread needs to be stickied

1 person likes this

I have found the same issue.  I ordered a new main board and just received it last week and installed it a few days ago.  It worked briefly but I noticed right away that the unit had produced a weird squeal-hum noise.  When i tapped the box, the relay dropped out and display showed the error "Error No Ground".

On the support site, i just found this article:

This explains the same thing you all described.  I am VERY irritated about this.  I purchased this board to fix my older unit that died, and now I need to add a Wi-Fi module just to change a setting!!!  Why is this "variable relay power" feature enabled by default?   

And another note the connectors are different on this board and not compatible to the older display and button on older stations. And you can't just by the cables needed on the OpenEVSE parts store.  I wish the part store would mention this concerning replacement for older charger stations.

1 person likes this

Just wanted to chime in-- just like Neon.leon I recently got a 5.5 board to replace the electronics (appears the old wifi module power cable got too close to to contractor and fried all my electronics... my error in cable routing but the new 5.5/wifi is better placed, at least) and I ran into both the relay opening and the incompatible button issue-- I'd second adding a note about the current button connector type.

Fortunately I got a wifi module with my new unit.   Changing to the recommended PWM settings appears to have fixed the issue (or at least its run for a few minutes now with that setting).

Might want to send emails to people getting 5.5 boards to warn them of this. If it weren't the middle of the night when I first had the opportunity to test it I probably would have torn down the unit and checked all the grounding lugs before searching for a support issue. :)

1 person likes this

I am once again disappointed by this feature because the solution DID NOT WORK for me. After purchasing a new WiFi module, waiting for weeks to receive it, and finally installing it, I find solution provided (the command $Z0 RAPI) fails to work. I’m extremely frustrated with this.

The relay still has a high pitch squeal/hum and the voltage reading on the relay coil is low, where I measure 5.7 VAC and 2.96 VDC.

I still don’t understand why this “variable relay power” feature is enabled by default. This can cause the relay contacts to burnout due to loose contact pressure and CAUSE A FIRE!!! I cannot use this EVSE in this condition.

I know the WiFi communication works since I can control the EVSE because I can pause charging, read charging current and other items. Plus when I enter the RAPI command $Z0 , I receive the response “<$OK^20”. By the way, documentation of this never mentions what a user should expect as a response.

First I want to note that I chose to set the “ms to run at 100%” as 200 milliseconds.

I have tried entering the values: $Z0200160, $Z0200194,$Z0200200, and $Z0200255 with no change found in the hum noise or relay coil voltage.

Note I calculated these values as:

160=63%, 194=76%, 200=78%, 255=100% Again I wish documentation would provide more examples of potential values to use.

I’m going to submit another trouble ticket on this and HOPEFULLY get a response.


@Neon.leon the command for 200 ms would be.

$Z0 200 160

$Z0 200 194

$Z0 200 200

$Z0 200 254

To disable the feature:

$Z0 255 255


I share your frustrations.  I've got 5 openEVSE units in my family.  The two newest with this feature are always causing me trouble.  Like you, I've done the suggested commands, but one of my units is very unreliable.

I've been a been fan of openEVSE for a while.  But this problem has left somewhat of a sour taste in my mouth. The charging equipment we use should be dead-on reliable.

Please post here if you come across any helpful solutions or if your new support ticket results in anything.

@Tyler The feature can be disabled with the $Z0 255 255 command.

@Neon.leon Your commands are missing the spaces. $Z0200160 should be $Z0 200 160.

Login or Signup to post a comment