Start a new topic

Firmware Update files April 2022


I need to update my open evse firmware to revision 7.1 or latest in order to be able to be able to get the correct TIME from the wifi board. 

the guide in the store at talks about three files: 





Am I missing anything or this guide is not up to date....?? 

where to I find those file? 

I have download the zip file "open_evse-8.2.0"

only the file flash.bat is to be found there.


The guide is not up-to-date.

A few problems arose as I attempted the firmware updating recipe at . . .

1) (scroll to the bottom for the "assets" ie files)

As of this writing, the Assets for 8.2.0 and 7.1.6 do not contain “flash.bat” nor “eeprom_24.bin”.  I pulled them from the 7.1.3 release instead.

2) The filename for firmware releases is now “openevse.hex”, not “open_evse.hex”.

3) The OpenEVSE ISP programmer that I was shipped in Oct2019, Order #6383, was a Polulu USB AVR Programmer v2.1, which shipped with a std. ribbon cable and IDC connector; therefore, the instruction in Step 4: (“The yellow wire on the 6 pin connector aligns with pin 1 of the ISP connector.”) is not applicable. Perhaps I was not sent a harness I was supposed to receive, or a previous programmer that OpenEVSE shipped had a different harness.


4) On my revision of the PCB (v4 Advanced), the DC-DC converter is too close to the ISP pins to allow for the IDC connector’s key; like Ed Hubbell, I had to shave off the IDC connector key to get it to fit to the pins. I see that later PCB revisions have moved the ISP pins to the left, and still other revisions have rotated the ISP pins 90°.

More notes and pictures (for a linux-based update) are here:

Those files are included with 7.1 but not 8.2.  I'm not sure if you need to but I would upgrade with all of the files to 7.1.x and then just flash the 8.2 file after the others.  That worked for me.  Only issue I ran into was my L2 Max would not go above 16A via the wifi gui but I put it in advanced mode and issued $SC 40 in the RASPI and it increased to 40A.  I then rebooted the wifi and I now have all expected options available in the drop down.

Nick, as you say the assets of 8.2.0 at only include openevse.hex .  They do not include the eeprom_24.bin and flash.bat files that are specifically referenced at ; you have to go searching for them; I found them under 7.1.3 at github. 

Then, this older flash.bat includes a reference to open_evse.hex, while the 8.2.0's firmware is named openevse.hex , the the older flash.bat won't work as-is.

IOW, you can use the guide as a sort-of sketchwork for updating the firmware, but with the caveat that some of the instructions are misleading, or just plain wrong (out of date).  In order to successfully flash a modern firmware, one has to have a level of competence that I feel should not be assumed by the author, because the guide is no longer a valid recipe.  It appears to be a dead/unmaintained document from years ago, and is the direct cause of probably dozens of people wasting hours trying to do what is implied is simple, when it's not.

Login or Signup to post a comment