Start a new topic

POST OK. Ground fault when car connected

I have just assembled my kit and having trouble getting it to charge my Leaf.

Repeatedly checked all connections as per the build guide and can't see any issues. Checked every connection is tight and secure.

Tested the J1772 cable for continuity to all wires and also for 150/480 ohm through proximity switch.

Tested ground connections through to the control board mounting screws (I'm guessing the current board is grounded through the standoffs?)
As it's a ground fault I've paid extra attention to the grounding block & connections.

Picture of the internals: Note that the power cable is a temporary 10A - charger is set to 6A charge.


It boots and completes POST tests OK.

WiFi is connected and functional.

Set to L2 for Australian 230V.

When I connect it to the car it goes through the following cycle:

Not connected (Green)

Connected (Amber? Can't quite remember)

Charging (0 amps) (Blue?)

Ground Fault (Red)

The car beeps on connection, then goes silent, no indicator lights on.

I've tried with GFCI enabled and disabled.

So far I've only tried it on one power point so haven't ruled out a ground fault on that point yet.

Any suggestions what to look at next very gratefully received.


Minor update.
I did some more checking and testing today.
Set the GFCI test enabled and then the unit returns "No Ground" on POST

Set it to Auto rather than L2. Faults out before it cycles the relay.

I have dismantled much of it and reassembled. 

Moved the GFCI coil to neutral for no other reason than I could.

Re-connected the most of the wiring.
Tested earth wire resistance from plug to J1772 - 4ohms. Also tested at every other point along the way - 4ohms or less.

Tried 3 different power points on different circuits in the house.

No change in behaviour.

I'm wondering if the house earth could be faulty? I'll take the unit to a friend's house and see if it's any different. I'll also see if I've got another plug or plug & cable just to rule that out despite everything metering out fine.

Very puzzled and frustrated!

Next update - still not resolved, but a step forward.

While checking continuity through the test wires I discovered the relay was jammed open. I wiggled it a bit and "click" it came free.

Now POST is successful on L2 and Auto.

Sadly when I plug it into the car the two seem to do some negotiation but then the charger web admin shows "EVSE error. No Earth". 

The car drops back to standby mode and the charger display goes red showing "Charging 0 Amps"

I'm now suspecting possibly a connection fault at the car plug. 

I'm not sure what the earth pin connects to in the car? The chassis? 

Can I plug the Unpowered charger to the car and measure resistance from the charger earth block to the vehicle somewhere to see if the plug is connecting properly?

I did a bit of searching and decided it looked like the J1772 ground pin connects to car chassis.

I plugged in the unpowered charger and checked continuity from the power plug earth pin through to the car chassis - 4 ohms, which is what I get testing at pretty much any other point too.

So there appears to be ground connections everywhere needed, the car and charger are talking, the relay is working ..... but the charger fails.

What a mission! This is starting to really P*** me off!

No doubt it'll turn out to be something relatively simple (like a new circuit board delivered from America to Australia. Or some stupid dodgy connection), but I'm done for now. No clue what else I can do or check.

Really looking forward to some knowledgeable advice.


Yet another update on this little saga.

Today, based on the fact I had continuity from car to ground, I disabled earth checking and tried to charge the car.

The car did it's usual beeps and flashes then went into charging mode, showing the correct status and charging state. Certainly appeared it was happily charging.

But the charger and the web interface both showed "Charging 0 amps"

So why is the car saying it's charging, but the charger says it's not delivering any current?

Makes me wonder if the CT's just aren't working properly, either in software or hardware?

I've unplugged and replugged the connectors.

It sounds like your relay is not closing, if it does not close the ground check will fail. 

We would recommend checking 

for any binding

that the contacts are about 2-3mm when open

If the relay is free and the contacts look good the relay hold power can be increased.

This was the solution.

Obviously I should have spent more time in the Troubleshooting area. 

I did't look at that post because in my case charging never started so I assumed that post was not relevant (it's titled "OpenEVSE stops charging and displays Error no Ground (Earth Ground)"). If charging never starts how can it stop?

Thank you very much.

Well, partial solution.

Today the relay stuck open again. Quite jammed when I opened the case. Took a bit of wriggling to get it free again. Couldn't see any obvious reason for it to be stuck.

Not much confidence left in this relay!

What can we do about arranging a replacement?


Hi Peter, we have had a report of jamming recently of the ring that secures the coil had come loose.  The repair is very simple and much easier than replacing the relay. It may be worth checking to see if this is the issue. 

The first step is to remove the tension tab that holds the relay arm.

Then lift the arm up and tilt back to expose the coil.

Check that the ring is secure. If it is not secured all the way around, use a screwdriver to pop it on.

This was indeed the problem. The ratchet washer was completely loose. Hopefully it stays where I've put it. Thanks.
Login or Signup to post a comment