Start a new topic

Timer and limits not working

Advanced Series 40A v5 kit

OpenEVSE 7.1.3

WiFi 4.0.0

I am having two problems, but I don't yet understand the OpenEVSE system well enough to know if they are independent, so I will present them both in case they are related. Resets and power cycling did not change these behaviors.

Problem 1: The Start and Stop times in the UI are not working. I can enter times and press the Set button (which then changes to Update and Cancel buttons), but the evse seems to ignore those values. The car started charging immediately even though it was not within the Start and Stop times; I paused it, and it did not resume at the Start time; I manually resumed after the Start time had passed, and it did not stop at the Stop time. The web UI and 2-line LCD both display the correct date and time, and the web UI shows the correct timezone (US/Los Angeles), but when I use the web RAPI UI to send "$GT", I get back ">$OK 165 165 165 165 165 85^1F", which doesn't look right. I tried using "$S1" to set the date and time, but that made no change to the results of "$GT". I had set the start time to 10pm and the stop time to 6am, and "$GD" returns ">$OK 22 0 6 0^16", which looks right.

Problem 2: When I set values for time limit or charge limit, when the evse reaches the limit, it pauses, but almost immediately resumes charging. The color on the web UI changes, the current drops to zero, but then the color changes back to the charging color and the current ramps back up. The behavior is the same for both time limit and charge limit.

The Pause function works as expected, and the current limit is working. I am currently plugged into 120V and have the output set at 8A. The evse tells me the car is drawing 7.7A while charging, so that looks good.



WiFi version 4.0 introduces a new timer system that allows multiple day of week schedules. All of this is managed with network time on the WiFi card. The curent User Interface has the same single timer that applies to all days of the week but this will change very soon.

WiFi Versions 3.x and prior uses a hardware RTC clock chip and battery and were managed by OpenEVSE controller with RAPI commands.

It seems you have both old and new timers setup that are conflicting with one another. please run the RAPI command $ST 0 0 0 0 to disable timers on the OpenEVSE controller. The old Start and Stop timers also did not work with a Session timer, It was one or the other not both.

I spent quite a while playing with the Timer and Limits. Here is a summary of my results.

  • Time limit and Energy limit are working for me, as long as I don't have any Timer values set. I assume having Timer values set was what led to the odd behavior I saw previously where it would momentarily stop charging once it hit the limit, but then start charging again within a few seconds.
  • No matter what I do, I can't make Start and Stop work. In all my testing below, the Limits were not set.
  • It looks like the web UI is setting the start and stop times in the controller. When I use $GD, that value changes to reflect the times I have set from the web UI. If I set Start=9pm and Stop=2am in the web UI, $GD returns 21 0 2 0. If I then Cancel from the web UI, $GD returns 0 0 0 0.
  • For completeness, I did use "$ST 0 0 0 0" a few times, but it did not make any difference.
  • If I try to set a Start time that is later in the day than the Stop time, it seems to completely ignore it (other than changing what I get back from $GD). I had assumed that a Start time of 10pm and a Stop time of 5am would make it charge overnight, but it behaves as if it is completely ignoring those values.
  • If I set a Start time that is earlier in the day than the Stop time, it goes into "Waiting" state when I press Set or Update, but it still doesn't start or stop at the entered times. The change into Waiting state happens whether it is in Not Connected or Charging state when I press Set or Update, and it happens whether or not the current time is within or outside of the Start and Stop times.

I'm looking forward to that new version that has updated Scheduling.



Login or Signup to post a comment