Start a new topic

WiFi no response after setup, and won't reset

Advanced Series 40A kit


WiFi 4.0.0

I assembled my Advanced Series 40A kit this week and was able to connect to it and enter the info to have it connect to my wifi network. I can see in my DHCP logs that it successfully gets an IP address, and it displays that, but I can't get any other response from it using ping or on a web page. I ran tcpdump on the AP it is connected to, and I can see the ICMP request being sent to the openevse IP, but there is no reply. At one point I saw a broadcast from the openevse IP address with the message "Who has 10.X.X.X? Tell 10.X.X.Y" where X.X.X is my computer and X.X.Y is the openevse, but I don't know what triggered that. And there appeared to be no response to that.

I figured I would reset the WiFi unit and try again with my other wifi network. With the unit on, I held down the GPIO0 button for well over 10 seconds. During that time, the two LEDs on the WiFi board cycled through green, red, and blue, over and over. When I released the button, the LEDs went back to green, and the display showed the IP address that my DHCP server had given it. When I looked in my DHCP log, I saw that the openevse had been going through the discover/request handshake about every 2 or 3 seconds while the button was being held down.

I have experience with Unix systems and hardware, but I'm new to OpenEVSE. I was unable to find anything in the forums that looked like this issue. I ordered the USB-to-serial kit from the OpenEV Store, so once I get that I should be able to reflash the software in the WiFi module if that's what's needed.




It sounds like you held down the Reset button not GPIO0. Here is the knowledge base article for factory reset:

Yes, it does seem to behave similarly, but not quite the same.

If I push and release the Reset button, the LEDs turn off very briefly and then flash red, green, blue, and back to solid green, meanwhile my DHCP log shows the four-step DHCP request cycle from the openevse box. The Display says "OpenEVSE WiFI 4.0.0" and then progresses to the other screens. If I press and hold the Reset button, it does nothing - it stops scrolling the messages on the display, and the light stays solid green - until I release it, upon which it does the reset. When I release the Reset button, the lights turn red in less than one second.

If I press and release the GPIO0 button (the button right next to the three-pin connector on my OpenEVSE WiFi V1 board), it does nothing. If I press and hold the GPIO0 button, it behaves as if I am pressing and releasing the Reset button over and over again, except that the display alternately shows "OpenEVSI WiFI 4.0.0" and "Access Point" (it actually shows "Access PointI 4.0.0", like it didn't erase the other message before writing Access Point). When I press and hold the GPIO0 button, the light first turns red after about 2 seconds. The time until the lights turn red again is just under 3 seconds.

What might cause the GPIO0 button to behave sort of like the reset button? I don't think it's possible to connect the wiring harnesses incorrectly, but I double-checked that anyway and did not see a problem. Is there a way a circuit board problem such as a solder bridge or open circuit could make this happen? Since the WiFi module is stuck to the case, I didn't want to try prying it off to look for something like that for fear I might damage the board by doing that.


Press and hold for less than 10 seconds enables Access Point Mode (sounds like this worked okay), If you continue to hold after 10 seconds it should run the factory reset.

I had tried pressing the GPIO0 button for less than 10 seconds, but that also didn't work.

In order to get more info, I unplugged the wifi module and connected it to a just-received FTDI USB to 5V TTL serial converter, then ran "screen /dev/ttyUSB0 115200" on my Linux box, which allowed me to see the output of the ESP32. I pressed the Reset button and watched it reboot, then I pressed and held the GPIO0 button - and it did what it was supposed to do, which I could see by the fact that both LEDs ended up blinking green.

I reconnected it to the controller, plugged in the box, and was able to go through the normal wifi initialization to connect it to my other wifi network, after which I was able to access the web UI and make my desired changes.

I will assume that my first problem, that I could not access the web UI, had something to do with the first wifi network I used. But I have no explanation for why the GPIO0 button would not do its thing when connected to the controller, but behaved properly when connected to the serial cable.

Anyway, the web UI is working now, so I'm happy and can move on to installing it on the wall and plugging in my car.

Login or Signup to post a comment