Start a new topic

Solar current mismatch?

Hi all,

Im a new user - setup the MQTT solar feed coming out of nodered based on the status of my house battery and the current grid cost. Im charging a 2016 Outlander PHEV.

The issue specifically im having is that I am sending the evse a solar value of 2000w, it is calculating (from my voltage feed) 8 amps available yet the unit is sending a pilot signal of 10a and the car is pulling 9.02a. 

Not sure if im missing something but I would assume that if 8a of available current is calculated it should be sending the car a pilot signal of 8a.

Is this behaviour expected? 




Hi Mike,

I'm having a similar problem, after just recently getting mqtt and my solar all setup correctly.

In my case, it starts at 6A and never moves off 6A despite there being plenty more current available :-(

I have a type 2 setup with import/export correctly updating, as well as voltage, in the EVSE every 10 seconds. When I got it going (while the sun was down) I was excited that it had everything it needed to divert solar power to the EV .... and then when I tried it, it didn't work :-(

I'm running latest firmware on both the EVSE and the WiFi controller (needed to update WiFi to get mqtt working at all).

I wonder if this is a bug, or we've both not set it up correctly .....

Anyone have any suggestions?




And now, after a bit more fiddling, it *is* varying the Charge rate.

It seems (just from observation) that it won't go above the Max Current set at the time PV divert is enabled.

It doesn't appear to respond to any changes made to that value AFTER PV divert is turned on.

Will keep monitoring it, but it seems to be working better for me now ....


Thanks Matt, Ive tried the above without success :( Disabled and re enabled PV divert.

Screenshot of what is happening now. 

I set max current to 10a. Restarted Openevse wifi checked that my changes were persistent then enabled PV divert then clicked on to PV divert and it waited for solar. Once solar was available (less than 0w displayed on the grid import export) it started changing at 9a and didn't stop or slow at all.

Very strange behaviour. 



If you are using Grid Import/Export + Positive values mean you are importing energy from the grid - Negative values are export. If you are just tracking household loads and generation at the main meter then you should use Negative values when you have excess solar and are exporting to the grid. OpenEVSE will use this excess. Your screenshot shows you are using importing 1695w.

If you are just tracking solar and not other loads use the PV Gen MQTT Topic and positive values.

Thanks for the reply support. 

I guess this is my problem, with the above screenshot im importing 1695w from the grid and EVSE is calculating that I have 0a available of solar to charge yet EVSE is sending a 10a pilot signal and the vehicle taking 9.02a? 

From my experience what ever I set the max current to, the charger will deliver when in eco mode. 

Regards and thank you for your time


@Mike Are you running the latest stable release 3.3.2?

Hi Thanks,

Yep running 3.3.2 on the wifi and 5.0.1 on openevse. 


Hi, having similar issues of current not correlating to the export value - did you have any success with your case? Ta

Login or Signup to post a comment