Start a new topic

Upgraded to V2.8.0 Successful - Wifi not accessible

Hi Everyone,

I attempted to upgrade the wifi from the UI to V2.8 (from 2.6)... I got a message that the upgrade the upgrade reported OK and even on the OpenEVSE - it said Wifi upgrade successful... however, I can't access it even after a restart.

Usually restarting the charger, it show wifi info, but it isn't anymore.

What should I do? Should I manually reload/reset the wifi module? How do I do that? Is there a guide?

I do have a USB programmer that I use to upgrade the Arduino firmware.



Hi Martin,

Cable arrived today and Huzzah updated to 2.8. Procedure worked as previously advised but don't forget to put the board into programming mode by simultaneously pressing both buttons. Obviously have to connect TX to RX and RX to TX for valid communications. Picture attached which indicates what the pins are on the Huzzah.

Regards, Stephen

(101 KB)

Hi Martin,

I'm in the same position as you in that I have just bricked the WiFi module upgrading to V2.8.

To answer your question, no reset on the board will bring it back so we are both faced with either sending it back to have OpenEVSE for them to replace the firmware (a courtesy service they provide) or do it ourselves. In my case as I live in Australia, I will try and do it myself as the postage cost will exceed the cost of the USB to Serial Adapter. You say that you already have a USB programmer so you may not need anything else? The board is actually an adafruit Huzzah (ESP8266) so if you search online, you should be able to find directions on how to flash it.

Please tell us how you get on and good luck!

Regards, Stephen

Hi Stephen, Thanks for your reply, nice to see that I'm not the only one in the same boat. The usb programmer I was referring to was the one for the Arduino board... I really didn't know that I needed another programmer for the Wifi module until I tried to connect it to it. Lol I read up and now I know that this programmer won't work. I did find one online but it also requires me to do some soldering to enable flashing... I'll give it a shot. :) It's all a learning experience isn't it? I believe what went wrong during the upgrade is that I pressed on the upgrade button a second time as there was no queues that showed that the upgrade was in progress... I pressed again thinking that the upgrade wasn't happening... I think that bricked it. The upgrade button should gray out when pressed with a "Please Wait" message... Or something of the sort. Do you know the software that is needed to reload and how to use it? Thanks. Martin


You should be able to find a board on eBay that you can connect to the ESP8266 without having to solder anything.

I bricked my board in exactly the same circumstances as you described so perhaps there is an opportunity to improve the software to prevent this from happening to other people.

The board I ordered is still a few days away so once I have successfully upgraded the firmware, I will indicate the method and software I used.

Regards, Stephen

Hi Stephen, I received the programmer and I totally messed up... I bought the classic ESP8266 programmer... But totally didn't think that I needed something specific to the Huzzah.... Argh .. not sure if I can even do anything with this thing... Where did you find your cable? Want to make sure I order the right thing this time... Thanks. Martin

Hi Martin,

Further to my last, I managed to find a old ESP8266 in my junk pile that had a microUSB socket for programming and power and thought I would see if I could upload the 2.8 firmware to establish the update process while I wait for the board to programme the Huzzah to arrive. Having loaded the correct drivers for the board, I downloaded NODEMCU FIRMWARE PROGRAMMER from a link on:

along with the 2.8 firmware (firmware.bin) from github and placed it in the root of drive C. I then configured the NodeMCU software as per 2.PNG and then selected Flash as per 1.PNG and after a few minutes, the update was complete. I was them able to login to the ESP8266 via WiFi as per normal so success!

Hope that this will be of some help when you get around to updating your board.

Regards, Stephen

(23.2 KB)
(31.8 KB)
Awesome! Great to hear Stephen! I just got my shipping confirmation from my eBay order. I'll use your the program you suggested and the steps and will let you know. Thanks so much for your help! :) Cheers

Hi Martin,

The following is a link to the one I purchased which should give you an indication of what you should be looking for:


Hi Stephen, Was just about to reply, that’s the exact one I go from a local supplier. :) I had a bit of an issue with the driver for Windows 10 but figured out that using an older driver works. I was able to flash it successfully. Just need to put it into the EVSE tonight to validate. Thanks so much for your help! Cheers Martin

Hi Martin,

Glad that you managed to get it sorted.

Suggest that you check it when plugged into the programming cable as it is powered and transmitting the WiFi signal so you can login rather than installing it and having to remove it again if not working.


Oh good tip! Just assumed it wouldn't work until connected to the Arduino board. I'll let you know how it goes. :)
I'm up and running! Thanks again Stephen!

Hi everyone,

Just wondering if anyone could help me out. I'm wondering if I bricked my wifi module... Is there a way to reset the firmware on it by any chance?

Login or Signup to post a comment