Start a new topic

WIFI constantly rebooting

 I've been trying for months to get the WIFI working on my EVSE.  It had an old firmware originally. I think one of the 1.0 versions.  Despite not having most of the newer features, it seemed to work good the year before.  .  I updated it to 2.5.2 several months ago when that was the latest version.  It wouldn't see any WIFI networks once I did that.  I rewrote the firmware thru USB-serial and it still wouldn't see any network.  There 10-15 WIFI AP's in range.  I tried 2.7.4 today, which it seemed to take (I got OK and now it shows that version on the System tab) and now not only do I still not see any networks, but the unit seems to reboot often.  I tried downgrading to 2.7.2 but it won't stay online long enough to take the firmware. 

Is this typical for the recent WIFI versions or do I maybe have a defective unit?

Yes, it does indeed sound like a corrupted unit. 2.7.4 has been totally stable on all the units that's it;s been testing on. What ESP WiFi device are you using? Is it the Adafruit Huzzah with the standard power supply? 

Doing a full erase before uploading as Chris suggested is good idea.

It sounds like you may have a corrupted upload. Can you write 2.7.4 with the USB-Serial? -b 1500000 -p COM4 write_flash 0x000000 firmware.bin

We would reccomend a full erase first. -b 1500000 -p COM4 erase_flash

Substitute COM4 with your COM port

Login or Signup to post a comment