Start a new topic

Simulating EV connection - Diode Check

Having put together OpenEVSE v4 with firmware 4.8.0, I'd like to simulate operation and test before I plug into a real EV.


Some very basic questions which I can't find answers for:

- Should I be able to fully test this, including all safety checks using an EVSE simulator?

- I've put together an EV Simluator (the v2 one on GitHub). However, no matter what I try, I always get a Vent Required error, and if I disable that, I get a Diode Check error.


I have connected CP through to a 1N4148 diode through a 2.74k resistance back to the Ground connection.


Should I have anything on PP at this stage to simulate cable connection? I've tried a 330Ohm resistance suggesting cable supports 64A, but still get the Diode Check error regardless.


At this stage, I still haven't connected 230V mains, but I would hope I should be able to get this far and GFCI, etc, would fail without mains, but diode checks should still check out OK. Or have I got that wrong?


Another point: according to the troubleshooting guide https://openevse.dozuki.com/Guide/Testing+Basic+and+Advanced/12?lang=en Step 3, first item (green bullet point) suggests "After a sucessful Power on Self Test OpenEVSE should enter State A - Ready and the LED/LCD should be Green.". I don't get this far:


When I power up (via DC) the OpenEVSE module, I get the splash screen, then the Vent test disabled notification, then the POST screen which lasts a couple of seconds. Then, I get for a very brief time, the "Charging" screen. That stays for about 0.2 seconds before turning red with the "EVSE ERROR DIODE CHECK" message. This happens regardless of whether I've connected my simulator circuit. So I presume it's not getting that far.


I presume v4.8.0 is fully tested and working? I did have a problem compiling it with Arduino IDE, but have tried Platform IO and that worked fine and I've been able to upload it to the board.

1 Comment

You can not test without mains power. 


The power supply powers both the 5v system (microprocessor) and 12v systems (pilot, relays).


1 person likes this
Login or Signup to post a comment