Start a new topic

Will my hardware support the latest firmware?

I have an openEVSE from 2013. I use it every day. Currently its running firmware 2.0.7 I think.

I would like to update to the latest firmware and add wifi.

Is there any reason I can't do this? Is the hardware compatible across all versions?

All versions of OpenEVSE are compatible with the latest version of firmware. It is worth upgrading if you have the color LCD with the RTC clock as you will get the temperature monitoring feature.

WiFi will also work with all versions, however the data available depends on the version of the OpenEVSE board. Versions prior to v2.5 do not have the circuit to measure current.


My LCD is multi coloured and the PCB says 'OpenEVSE RGB + RTC'.

How do I tell the version of the OpenEVSE board? Mine says 'OpenEVSE Plus' on the top side, but I can't see any other markings. 

One thing, my CT (supplied with the kit) is a CR8420-1000-G. Looking at other threads this will need to be changed to allow current measurement? Is it a direct fit?

Okay, the LCD will support temperature monitoring.

To measure current you need to add a second coil it had a 2 pin connector. The boards that support current measurement have a 2 pin connector close to the connector for the CR8420-1000-G. Can you post a picture of your OpenEVSE board?


the blue heat shrink cables go to the existing CT.

do you mean an additional connector?

Your Board is the V2 which does not have the current measurement circuit.


Looks like my 'basket' will be getting bigger!

So what can wifi log from this version? Do the other remote functions still work on this version if I upgrade the firmware?

All RAPI functions will work such as adjusting current, stop, start, etc.

Logging will be temperature only instead of Current and Temperature.

Login or Signup to post a comment