Start a new topic

Not updating data after new firmware to Wifi module

Chris, I went ahead and updated the new Development firmware to the Wifi module.


Open OpenEVSE_RAPI_WiFi_ESP8266.ino in the Arduino IDE.

Compile and Upload as normal

Upload web server files using the ESP8266 Data Upload tool under Arduino tools.

Not its connected to the home wifi but not updating any data. I have entered the device key and node info. I can hit the local page and see all the info. All information is correct. Just not updating any data to site.

Is there any steps I am missing.



Status page shows everything correct but 0 successful packets on main page

Successful packets:
0 of 0


RAPI packets:
14 of 12

Firmware: 3.11.3
Protocol: 1.0.3
Firmware: D1.0.2

Hi Chris - 

I'm having similar issues to Salman with no data going in to Emoncms. Also have the device key and node in place.

I'm using firmware 3.11.3 on the EVSE, and the ESP8266 is running the version you committed on Saturday 7/9. 

The EVSE is getting data from the ESP, because it updates the IP to the LCD, plus I can SEND RAPI commands to sleep it, etc, so I know that's fine, but I'm suspicious that the ESP isn't hearing the EVSE. 

Big side note here - I do have to say that I was using a bare ESP module for all the old firmware , and it WAS working fine until I updated the EVSE to 3.11.3, at which point NO data came out. I don't know quite what this all means, but it was a thing. 

That old ESP was a crappy 512K version, which can't fit the program and the SPIFFS of the new ESP firmware, so I stuck the firmware on a WeMos D1 and this is where I can properly SEND data to the EVSE. The problem is that the ESP doesn't hear anything that the EVSE is saying, and I'm actually suspicious that the cut-rate USB to Serial chip on it is holding the RX line high or low rather than letting it float, so I may not actually be saying ANYTHING useful with this post.

I will hook it up to a proper clean module and give it a run this week and let you know whether or not I get it up and running.

Also, new interface looks fantastic! Thanks for the hard work!


Update - Yes, it was the USB to Serial chip that was holding the RX line high through a 470 ohm resistor, which I removed, so the EVSE and ESP are talking as they should,  but for sure, no updates to EmonCMS. I have not tried hard coding the API key, which is now a pain in the neck seeing as I just disconnected that resistor :-)

Thanks again,

Andy Baker


I do not see any traffic on your Device Key so it is not making it to the server.



What is the user or Email for your account. I will see what I can see on the server.


Chris, anything you can think off I can try?

I have checked everything I could. It connects my my local wifi and I can get to it via IP assigned from my DHCP server. Everything on the Status page looks great. I can send RAPI command and get a respond.

Its only not updating the EmonCMS site.

I even hardcoded the Device key/apikey to the firmware before I programmed after resetting the EEPROM.

I also tried new firmware D1.0.3 with no luck.

At this point any advice or help from anyone would be greatly appreciated.


What version of the ESP8266 Board Manager are you using? I am developing on 2.2.0.

I am using 2.3.0, I will downgrade to 2.2.0 and see if that helps


Chris, I went and downgraded to 2.2.0 and re-flashed the Module. What do you know.

Its working now.

Thank you so much


Hi Chris, Hi Salman,

I also down-graded to 2.2.0 and everything is going swimmingly once again, updates to Emoncms and all. Also, adding the OTA update was awesome and brilliant. Worked flawlessly, to my amazement. Usually these kinds of things are dicey at best. Well done. 


Since the lsst update of commit 61, it only updates for 1st 10min then stops updating.

After 10mins it only send inputs Key "1" update. Any ideas?

Login or Signup to post a comment