Start a new topic

Did I blow up my evse board AND my monochrome LCD?


So today I was trying to get RAPI working with a Raspberry Pi Zero as a fun day project. Little did I know that I would end up blowing up the board and likely my LCD...

Background on the hardware I'm using: I have a Version 3 board in a (former) Leviton EVSE which I've reused the contactor(240v coil), J1772 cable, junction blocks, and case. It's worked great for about a year without issue. I have a monochrome LCD with RTC that I got from Glenn D which I use the timers for the station. The Raspberry Pi was powered from a separate 120v wall wart.

So this morning I tried to hook up the Raspberry Pi to the FTDI port on the openEVSE using an adafruit serial console cable (without connecting the power lead on the EVSE side). I couldn't get any data and after swapping the tx and rx lines around a few times, realized I had an older firmware 3.3.X on the board and it was likely that RAPI wasn't enabled. So, I set off getting the latest HEX and uploading it to the board. It took it well and I changed my current and timer settings to match their previous values. Tested charging on the car for a minute or two and it worked well (Wh went up, neat!). I then tried bringing up a serial console again and still no data. I then tried swapping tx/rx lines again and that's when the problem started...

When I powered up the station after swapping those lines around, I got no backlight but I could see the LCD had squares for the top row. Power cycled, nothing, reuploaded firmware and the LCD came back but as soon as I pulled the programmer and powered back up, dead again. I tried uploading a 3.9 v of the firmware no change. So I figured I ether zapped something with some static when doing those rx/tx swaps, or I may have accidentally put the red 5v on one of the rx or tx lines one of the times by accident. Ether way, I figured my trusty V3 board was looking pretty dead.

I fortunately have another openEVSE, this one is an older Burbari (sp?) one that Glenn D put together and it has a simple RGB LED on the display board. I wanted to use it while I wait for a replacement board from Chris, but I need to drop the current down to 16 amps because that's my current wiring available (20 amp circuit) where I'm at. Sadly, the LCD from my main station doesn't want to work on my other EVSE. It also gives me squares on the top row with no backlight.

For shits and giggles I tried the LED display board on my dead evse but it didn't work. I put it back on the burbari board and it's working fine.

So now I'm a bit stuck and lost. I can use my backup openEVSE on 120v... but if try to use it on 240v it's currently set to put out a 24 amp pilot so I can't use it with my Fit EV. I'm pretty scared of trying to use the console cable on my second EVSE and I don't think serial is even enabled on it anyway.

Any suggestions very much appreciated. Fortunately I have nearly a full charge and have a hybrid available if I need to drive far this weekend. I ordered a V4 board with RGB display with 1 day shipping before posting this.


It should be very difficult to blow up a board with RX TX and 5v as All the pins General Purpose IO and are 5v tolerant. I would recommend reloading firmware with the flash.bat file so all the fusebits are reset. Here is a link to the latest firmware and flash.bat.

Hi Chris,

For some reason, my programmer isn't recognized with that flash bat (this is just some cheap usbtinyisp off ebay). I am familiar with avrdude though, and I can just program the fuses directly. What are the values?



-U lfuse:w:0xFF:m -U hfuse:w:0xDF:m -U efuse:w:0x05:m

Thanks! I'll try it when I get home. Curious what the squares mean with no backlight. Is that an error condition of no i2c signal to the display, or something? I was thinking today, perhaps the diy/Burbari board doesn't have the LCD stuff compiled in. If resetting the fuses doesn't work on the v3 board, is it safe to upgrade to the latest firmware on the DIY board? Nothing special going on with it other than using a 12v relays instead of a 240v contactor.

Yeah the blocks on the LCD means it has received nothing over i2c.

Success!!! Re-flashing the fuses and the firmware did it. Don't know why the fuses would crap  out but it seems like it's back to normal. Thanks Chris!

Thinking maybe I put the wifi dongle a bit too close to the screen maybe? RF coupled into the board could do some crazy things I guess.

Login or Signup to post a comment