Start a new topic

Mqtt not connected

Hi, I am trying to set up MQTT but i cannot get the openevse settings right so it won't connect. I believe the problem is the host name but I have tried everything I can think of, the IP of the computer running the broker (a Victron GX device), the openevse wifi IP, my laptop IP where i am running MQTT explorer. You can probably guess that I don't know what I'm doing with these wild stabs in the dark.

The Openevse seems to be connected to the wifi, but in the MQTT settings it says "not connected".


Any help would be appreciated.

The MQTT server setting should be the IP address of the broker. You should be able to use the same settings on OpenEVSE as you are using in MQTT explorer.

I tried that IP but no luck. 

I read that the username and password can be left blank, is that OK?


firmware update required or something ?

No firmware update should be necessary. Username and password are optional,.it just needs to match the broker setup.

Then all is as it should be... except it won't connect !

Is there a way to troubleshoot this ?

I thought I would try the Openevse android app instead to see if that would work but I can't find it anywhere, not on Google play anyway. 

I recall (many years ago) that when I had a blank username/password on the broker and hence blank on my evse, it would not connect. Once I added a username/password on the broker and on the evse, it connected. This may help you. 

1 person likes this

Thanks, that might well have been it. I got it running by restarting the whole wifi process and this time I left the emonpi name and password. I also updated the wifi FW. It connected to MQTT straight away.

1 person likes this

Mind you, I haven't added a username and pass on the broker which is a Victron Cerbo GX...

Login or Signup to post a comment