Start a new topic

ESP32_WiFi_V4.x compile failed missing <Arduino.h>


Hi all,
i'm a newbie in Platformio, trying to compile the ESP32_WiFi_V4.x code but stuck with this error in the subject.
The <Arduino.h> file can be found at:
Here is the relevant part of the build log:
Building in release mode
Compiling .pio/build/openevse_wifi_v1/src/LedManagerTask.o
src/LedManagerTask.cpp:5:10: fatal error: Arduino.h: No such file or directory
* Looking for Arduino.h dependency? Check our library registry!
* CLI > platformio lib search "header:Arduino.h"
 #include <Arduino.h>
compilation terminated.
Compiling .pio/build/openevse_wifi_v1/src/MongooseOcppSocketClient.o
*** [.pio/build/openevse_wifi_v1/src/LedManagerTask.o] Error 1
In file included from src/MongooseOcppSocketClient.cpp:11:
src/net_manager.h:4:10: fatal error: Arduino.h: No such file or directory
I can't seem to find any topic regarding this issue. It might be I missed something to install/configure.
Tried with Platformio Core and VSCode, same error.
Any help would be appreciated.
Thank you.

Login or Signup to post a comment