Start a new topic

problems setting up MQTT solar integration from OpenEm on OpenEVSE


I've had emonpi running for a few weeks now with solar working great.

Just build the OpenEVSE hardware.  Brilliant well done everybody.

I've followed the setup for the services tab in the OpenEVSE web app.

But i don't have the default login values.  As mentioned in the setup text.

I just get "connected : No" and i guess I'm aiming for 'connected: yes'

My user account on the EmonPI doesn't work here either.

Does anyone know what the default user/password is?

Or a way to reset the OpenEVSE so i can start again?

Any help greatly appreciated.  

You need to enter in the hostname or IP address of your emonPi. By defult the hostname is http://emonpi, on some networks it's http://emonpi.local. However, hostname lookup does not always work, therefore best to use IP address, however you would need to ensure the IP address does not change by allocating it as 'reserved' on your router.

The default username is: "emonpi"

default password is "emonpimqtt2016"

Then enter the MQTT feed of your Grid import export (must be positive import & negative export) e.g. emon/emonpi/power1 for CT` or emonpi/emontx3/power1 for emonTx CT`. 

Using the 'grid' feed will divert the excess solar PV, if you want to divert all the solar PV use the solar pv gen topic directly. 

That's working great now.  Thanks!!!!

Late afternoon in the UK and export just dropped below 1kW.

It's showing 6A correctly.  I'll have to wait till tomorrow to watch it tracking the solar output.  :-)

For anyone with a similar problem and reading this, a little more info....

My EmonPI has a CT on the solar gen and the other CT on grid.

I setup the EmonPI for default solar monitoring.

In OpenEVSE  "Basic topic" is emon,

I set "Grid topic" to emon/emonpi/power1 

Fantastic! Great to hear. The link to our setup guide for the EmonEVSE should be useful to other users. We also have some video guides linked on this page: 

Hi, also have a similar problem. The energy monitoring is connected, put MQTT (required for eco) will not connect. I've confirmed the topic is published by looking at it in MQTT lens. Any ideas?






Just an update. It continues to say "Connected: No".

Base topic is continually populated with hexidecimal text.

Firmware:    5.0.1
Protocol:    4.0.1


@Robert can you try updating to the latest firmware?

Download firmware.bin to your device and then upload and upgrade to the WiFi Module.

I've uploaded the firmware. I have no problems with "Energy Monitoring" however, I cannot seem to get the MQTT to connect.

A bit of background, I'm running Emoncms v10.2.4 installed onto a raspberry pi x86 virtual machine.

I simulated the vrms with a mosquitto_pub command and I've been checking they are published using mosquitto_sub.


Just a thought here, but check your emonhub log and make sure that the "voltage topic" is the same as in the log.

ie the exerpt from the log on mine looks like this:

2020-09-17 20:23:39,939 DEBUG MQTT Publishing: emon/WillHenge/vrms 248.03

So my voltage topic is:


Also: in the emonhub config file is there an MQTT section, does it look like this:


    Type = EmonHubMqttInterfacer


        mqtt_host =

        mqtt_port = 1883

        mqtt_user = emonpi

        mqtt_passwd = emonpimqtt2016


It's strange that I get writeapi connectivity to emoncms, yet I do not get MQTT connectivity.

I checked the topic was being published using mosquitto_sub from other computers on my network.

I also tried numerous factory resets and also set up emoncms on both a raspberry pi and a VM.

The problem was finally solved getting openevse to connect to a different wifi AP to host the network.

Login or Signup to post a comment