Start a new topic

MQTT client does not connect to

I tried the MQTT capabilities of version V2.7.8 but cannot succeed = always got "connected no". 

While emoncms connection is working I also tried to activate MQTT, put as Host, put a generic name in "base topic" left username and password empty since there is no authentification but never got a connection. neither data published (tested with MyMQTT from mobile).

Also started a mosquitto server on a dedicated server on internet, setup with IP address as "Host" but same result.

Am I doing something wrong ? or something is broken in V2.7.8 ? 

(98.8 KB)

Do you have a firewall or proxy that may be blocking external connections to the MQTT ports?

Using mymqtt app from mobile and from same wifi network works fine. I can publish and get feedback from subscribe. Really looks like it comes from wifi module. Is there a way to troubleshoot? A log file? Thank you.
And there is no restriction for outgoing connections on my router.
Login or Signup to post a comment